summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-11-20 12:02:36 -0700
committerMark Wagie2024-11-20 12:02:36 -0700
commit0f3c8b8df47f4ea2a8b44fbd0f19fffe1ec40684 (patch)
tree8c5f8c9b7a6d94f3c2cd8365e406d89ff3630a18 /PKGBUILD
parent3e19b6ee8668d26dd1b460e2a894a0daa69b7ed3 (diff)
downloadaur-0f3c8b8df47f4ea2a8b44fbd0f19fffe1ec40684.tar.gz
4.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74196e530a77..bc2becbf78f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=ente-auth
pkgdesc="Open source 2FA authenticator, with end-to-end encrypted backups"
-pkgver=4.0.2
+pkgver=4.1.1
pkgrel=1
-_flutter_ver=3.24.3
arch=('x86_64' 'aarch64')
url="https://ente.io/auth"
license=('AGPL-3.0-or-later')
@@ -19,9 +18,9 @@ makedepends=(
# 'chrpath'
'clang'
'cmake'
- 'fvm'
'git'
'ninja'
+ 'unzip'
)
source=("git+https://github.com/ente-io/ente.git#tag=auth-v$pkgver"
'git+https://github.com/ente-io/sentry-dart.git'
@@ -29,14 +28,14 @@ source=("git+https://github.com/ente-io/ente.git#tag=auth-v$pkgver"
'git+https://github.com/simple-icons/simple-icons.git'
'git+https://github.com/abhinavkgrd/ffmpeg.wasm.git'
'git+https://github.com/ente-io/PhotoSwipe.git'
- 'ente_auth.desktop')
-sha256sums=('ffb5c750bb8e371ac966716cf3b42fa60771b0d57dbc90724c9ed2282740736b'
+ 'enteauth.desktop')
+sha256sums=('1e9ee6bc3fd7d5e348bb9f592bcfab1b77a98488c5dec08f3fb7f12d95897e80'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '92368080b3a0381ede798c4fc76bce22dc3b4bdc0f2c01b317bb20f77aaf4fd6')
+ 'cc06c91a260d04fd7f62396a253702fb44c93125492235af022d2d417b2dcf78')
prepare() {
cd ente/auth
@@ -48,27 +47,28 @@ prepare() {
git config submodule.web/apps/photos/thirdparty/photoswipe.url "$srcdir/PhotoSwipe"
git -c protocol.file.allow=always submodule update
- export FVM_CACHE_PATH="$srcdir/fvm"
- fvm install "${_flutter_ver}"
- fvm global "${_flutter_ver}"
+ export FLUTTER_HOME="$srcdir/ente/auth/flutter"
+ export PATH="${FLUTTER_HOME}/bin:${PATH}"
# Disable analytics
- fvm flutter --disable-analytics
+ flutter --disable-analytics
# Download dependencies
- fvm flutter pub get
+ flutter pub get
}
build() {
cd ente/auth
- export FVM_CACHE_PATH="$srcdir/fvm"
- fvm flutter build linux
+ export FLUTTER_HOME="$srcdir/ente/auth/flutter"
+ export PATH="${FLUTTER_HOME}/bin:${PATH}"
+ flutter build linux
}
check() {
cd ente/auth
- export FVM_CACHE_PATH="$srcdir/fvm"
- fvm flutter test
+ export FLUTTER_HOME="$srcdir/ente/auth/flutter"
+ export PATH="${FLUTTER_HOME}/bin:${PATH}"
+ flutter test
}
package() {
@@ -80,16 +80,16 @@ package() {
FLUTTER_ARCH=x64
fi
- install -Dm755 build/linux/${FLUTTER_ARCH}/release/bundle/ente_auth -t \
+ install -Dm755 build/linux/${FLUTTER_ARCH}/release/bundle/enteauth -t \
"$pkgdir/opt/$pkgname/"
cp -r build/linux/${FLUTTER_ARCH}/release/bundle/{data,lib} "$pkgdir/opt/$pkgname"
install -d "$pkgdir/usr/bin"
- ln -s "/opt/$pkgname/ente_auth" "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/enteauth" "$pkgdir/usr/bin/"
- install -Dm644 assets/icons/auth-icon.png "$pkgdir/usr/share/pixmaps/ente_auth.png"
- install -Dm644 "$srcdir/ente_auth.desktop" -t "$pkgdir/usr/share/applications/"
- install -Dm644 linux/packaging/ente_auth.appdata.xml -t "$pkgdir/usr/share/metainfo/"
+ install -Dm644 assets/icons/auth-icon.png "$pkgdir/usr/share/pixmaps/enteauth.png"
+ install -Dm644 "$srcdir/enteauth.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 linux/packaging/enteauth.appdata.xml -t "$pkgdir/usr/share/metainfo/"
# Remove insecure RUNPATH pointing to build dir
# chrpath --delete "$pkgdir/opt/$pkgname"/lib/*.so