summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Morgan2021-05-02 02:53:00 +1000
committerChris Morgan2021-05-02 02:53:00 +1000
commitd6b35e6777b5ca3a3b70650f672451c70c354aec (patch)
tree0254cba14936771a196b35ddb0a38f210c474ece /PKGBUILD
parent0a96444171f04469636f12c41855b286c0b99cd8 (diff)
downloadaur-d6b35e6777b5ca3a3b70650f672451c70c354aec.tar.gz
Make it build, and adhere to Arch standards more
• Its vendored qwt-lib thing needs a straightforward patch because of something that I hear Qt 5.15 broke. • Git submodules are supposed to be specified as sources and sorted out in prepare. This was incidentally moderately necessary to sort out because the qwt patch needs the submodules to be up to date, so either the patch application had to be shifted to build, or the submodules to prepare. • Improve the package version by pulling something from Git. In theory this package should probably also be renamed to entropy-piano-tuner-git, but upstream looks pretty dead. I dunno. Anyway, 1.2.0.r27.gee7857a > git. (And not just in meaningfulness; in version comparison, too, so an epoch bump isn’t needed.)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 29 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9479093cdf3d..cef1a39d1351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Damm <autama@nurfuerspam.de>
pkgname=entropy-piano-tuner
-pkgver=git
+pkgver=1.2.0.r27.gee7857a
pkgrel=1
pkgdesc="Free Software for Piano Tuning"
arch=('i686' 'x86_64')
@@ -8,18 +8,43 @@ url="https://gitlab.com/tp3/Entropy-Piano-Tuner"
license=('GPL3')
depends=('qtmidi-qt5' 'qwt' 'libuv' 'hicolor-icon-theme' 'qt5-multimedia' 'fftw' 'qt5-declarative')
-source=(git+https://gitlab.com/tp3/Entropy-Piano-Tuner.git rpath.patch)
+source=(git+https://gitlab.com/tp3/Entropy-Piano-Tuner.git
+ git+https://gitlab.com/chwick/fftw3-qmake.git
+ git+https://github.com/libuv/libuv.git
+ git+https://gitlab.com/chwick/qwt-lib.git
+ git+https://gitlab.com/tp3/tp3log.git
+ rpath.patch
+ qwt-lib-qt5.15.patch)
md5sums=('SKIP'
- 'e7f34645ebe707be6d417f1f4bc31ebd')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e7f34645ebe707be6d417f1f4bc31ebd'
+ 'ec874c86d32d0e4a7e4acbfb8262c86d')
+
+pkgver() {
+ cd Entropy-Piano-Tuner
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
prepare() {
cd Entropy-Piano-Tuner
+
+ git submodule init
+ git config submodule.thirdparty/fftw3.url $srcdir/fftw3-qmake
+ git config submodule.thirdparty/libuv/libuv.url $srcdir/libuv
+ git config submodule.thirdparty/qwt-lib.url $srcdir/qwt-lib
+ git config submodule.thirdparty/tp3log.url $srcdir/tp3log
+ git submodule update
+
patch -Np1 -i ../rpath.patch
+ # Qt 5.15 broke QPainterPath stuff; fortunately it’s an easy fix.
+ patch -Np1 -i ../qwt-lib-qt5.15.patch
}
build() {
cd "Entropy-Piano-Tuner"
- git submodule update --init
rm -rf build
mkdir build