summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsnafu2019-02-08 16:31:59 +0100
committersnafu2019-02-08 16:34:30 +0100
commit1bb0bb3f52d8ac8a1d29f535367b7ab56d2e7b3d (patch)
tree8495cb9d7e6ab48d3c62c1f925856a523f2c28d3 /PKGBUILD
parent84423104b6a9ba33d15279d5ead8d8aee564afe9 (diff)
downloadaur-1bb0bb3f52d8ac8a1d29f535367b7ab56d2e7b3d.tar.gz
bump to 4.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 149e63928bfd..6d98e93b9407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: snafu
-pkgname=env-modules
-pkgver=4.1.4
-pkgrel=1
+pkgname=(env-modules)
+pkgver=4.2.1
+pkgrel=0
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
arch=('i686' 'x86_64')
@@ -13,15 +13,15 @@ makedepends=()
checkdepends=('dejagnu')
optdepends=()
provides=()
-conflicts=(env-modules-tcl)
-replaces=(env-modules-tcl)
+conflicts=(env-modules)
+replaces=(env-modules)
options=()
install=env-modules.install
changelog=
source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" zshcomp.patch)
noextract=()
validpgpkeys=()
-md5sums=('c19bff662003fad79f92a89b9ad47139'
+md5sums=('f4710af570b07153c7571967441ea4fe'
'48195d9f1c157c17b5c07e3997739f9c')
# Install locations:
@@ -36,15 +36,13 @@ backup=("${config_path:1}/${moduledir}/init/modulerc")
prepare() {
cd "modules-$pkgver"
- # uncomment if you don't won't the zsh-completion patch or if it doesn't work for you
+ # comment if you don't won't the zsh-completion patch or if it doesn't work for you
patch -p1 < ../zshcomp.patch
}
build() {
cd "modules-$pkgver"
-
- # heavy-weight default -- remove examples/docs
./configure \
--prefix=/usr \
--docdir=$install_prefix/share/doc/$moduledir \
@@ -73,8 +71,8 @@ package() {
_profiled="${pkgdir}${profiled}"
mkdir -p "$_profiled"
- ln -s ${config_path}/${moduledir}/init/profile-compat.csh $_profiled/env-modules.csh
- ln -s ${config_path}/${moduledir}/init/profile-compat.sh $_profiled/env-modules.sh
+ ln -s ${config_path}/${moduledir}/init/profile.csh $_profiled/env-modules.csh
+ ln -s ${config_path}/${moduledir}/init/profile.sh $_profiled/env-modules.sh
# Work around, since module needs <PREFIX>/init for autoinitialization
ln -s ..${config_path}/${moduledir}/init ${pkgdir}/usr/init