summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsnafu2017-11-01 18:44:04 +0100
committersnafu2017-11-01 18:44:04 +0100
commitb357f3d14e41f1c4d21cec44f08aaf3097ed9c56 (patch)
tree575c59ffee3f49ced501d61fb7f6b1ad17a18c8a /PKGBUILD
parent383796bf9fc9cc258b377c2f3a3f279cf70aebe6 (diff)
downloadaur-b357f3d14e41f1c4d21cec44f08aaf3097ed9c56.tar.gz
update to 4.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 50 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbc66cb54fff..33d70fec9089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: snafu
pkgname=env-modules-tcl
-pkgver=1.832
-pkgrel=5
+pkgver=4.0.0
+pkgrel=0
epoch=
-pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile (tcl-only-version)."
+pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/modules/"
license=('GPLv2')
@@ -13,43 +13,66 @@ makedepends=()
checkdepends=('dejagnu')
optdepends=()
provides=()
-conflicts=()
-replaces=()
+conflicts=(env-modules)
+replaces=(env-modules)
options=()
-install="env-modules-tcl.install"
+install=env-modules-tcl.install
changelog=
-source=("https://sourceforge.net/projects/modules/files/Modules-Tcl/modules-tcl-$pkgver.tar.gz" "zshcomp.patch")
+source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" zshcomp.patch)
noextract=()
validpgpkeys=()
-md5sums=('3a40bf6177cc438481672ce028544828'
- '2e1bee23178b74872fd1c78c1cac8053')
+md5sums=('454dba418b1556d2fd5de753fbbabe0b'
+ '2c6c0e8095d624da825e9a2938de0582')
-moduledir=modules-tcl
+# Install locations:
install_prefix=/usr
config_path=/etc
+profiled="/etc/profile.d"
+moduledir=modules
-backup=("${config_path:1}/$moduledir/init/modulerc")
+backup=("${config_path:1}/${moduledir}/init/modulerc")
-build() {
- cd modules-tcl-$pkgver
+
+prepare() {
+ cd "modules-$pkgver"
+
+ # uncomment if you don't won't the zsh-completion patch or if it doesn't work for you
patch -p1 < ../zshcomp.patch
- ./configure \
- --prefix=$install_prefix \
- --docdir=$install_prefix/doc/$moduledir \
- --initdir=$config_path/$moduledir/init \
- --modulefilesdir=$config_path/$moduledir/modulefiles \
- --disable-set-binpath --disable-set-manpath
-
- make
+}
+
+build() {
+ cd "modules-$pkgver"
+
+ # lightweight default -- uncomment example/doc for heavy weight
+ ./configure \
+ --prefix=/usr \
+ --docdir=$install_prefix/share/doc/$moduledir \
+ --initdir=$config_path/$moduledir/init \
+ --modulefilesdir=$config_path/$moduledir/modulefiles \
+ --disable-set-binpath \
+ --disable-set-manpath \
+ --disable-compat-version \
+ --disable-example-modulefiles \
+ --disable-doc-install
+
+ make
+}
+
+check() {
+ cd "modules-$pkgver"
+
+ # uncomment if you run into problems... takes quite a while
+ #make -j1 -k test
}
package() {
- cd "modules-tcl-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "modules-$pkgver"
+ make -j1 DESTDIR="$pkgdir/" install
- _profiled="$pkgdir/etc/profile.d/"
+ _profiled="${pkgdir}${profiled}"
mkdir -p "$_profiled"
- ln -s $config_path/$moduledir/init/profile.csh $_profiled/env-modules-tcl.csh
- ln -s $config_path/$moduledir/init/profile.sh $_profiled/env-modules-tcl.sh
+ ln -s ${config_path}/${moduledir}/init/profile.csh $_profiled/env-modules.csh
+ ln -s ${config_path}/${moduledir}/init/profile.sh $_profiled/env-modules.sh
}
+