summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsnafu2017-05-07 20:55:22 +0200
committersnafu2017-05-07 20:55:22 +0200
commitfdaa553f5d50882738184f3adfcd30f781a06044 (patch)
treee7a706f54d05903f78a3820f7739903a7980748b /PKGBUILD
parent25b8a3a9e6b347b6559633c2e61166a01ba7ccb2 (diff)
downloadaur-fdaa553f5d50882738184f3adfcd30f781a06044.tar.gz
zsh-completion patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 477063c36b8b..f46f03b23e95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=env-modules-tcl
pkgver=1.832
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile (tcl-only-version)."
arch=('i686' 'x86_64')
@@ -19,14 +19,25 @@ backup=()
options=()
install=
changelog=
-source=("https://sourceforge.net/projects/modules/files/Modules-Tcl/modules-tcl-$pkgver.tar.gz")
-md5sums=('3a40bf6177cc438481672ce028544828')
+source=("https://sourceforge.net/projects/modules/files/Modules-Tcl/modules-tcl-$pkgver.tar.gz" "zshcomp.patch")
noextract=()
validpgpkeys=()
+install="env-modules-tcl.install"
+md5sums=('3a40bf6177cc438481672ce028544828'
+ '4b7a5d66a1668fac5b3837723edceea4')
+
+install_prefix=/usr
build() {
cd modules-tcl-$pkgver
- ./configure --prefix=/usr --disable-set-binpath --disable-set-manpath
+ patch -p1 < ../zshcomp.patch
+ ./configure \
+ --prefix=$install_prefix \
+ --docdir=$install_prefix/doc/modules-tcl \
+ --initdir=$install_prefix/env-modules/init \
+ --modulefilesdir=$install_prefix/env-modules/modulefiles \
+ --disable-set-binpath --disable-set-manpath
+
make
}
@@ -36,7 +47,6 @@ package() {
_profiled="$pkgdir/etc/profile.d/"
mkdir -p "$_profiled"
- ln -s /usr/init/profile.csh $_profiled/env-modules-tcl.csh
- ln -s /usr/init/profile.sh $_profiled/env-modules-tcl.sh
+ ln -s $install_prefix/env-modules/init/profile.csh $_profiled/env-modules-tcl.csh
+ ln -s $install_prefix/env-modules/init/profile.sh $_profiled/env-modules-tcl.sh
}
-