summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKasei Wang2021-05-11 14:58:19 +0800
committerKasei Wang2021-05-11 14:59:50 +0800
commit77b7f99bfaff3a0f6d498c2d71ffe375a4f41a69 (patch)
tree6ebbc5c5dbeea3b75861b2b3d4149c01e7f3df53 /PKGBUILD
parente9da579619fbeddba10e5ccb250d3860ac44c680 (diff)
downloadaur-77b7f99bfaff3a0f6d498c2d71ffe375a4f41a69.tar.gz
updpkg: envoyproxy 1.18.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f438db872cb..d8e60cd0b32f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,47 @@
# Contributor: kXuan <kxuanobj@gmail.com>
pkgname=envoyproxy
-pkgver=1.15.0
+pkgver=1.18.2
pkgrel=1
pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
arch=('i686' 'x86_64')
url='https://envoyproxy.io'
license=('Apache2')
makedepends=(
- 'bazel'
'cmake'
+ 'clang'
'git'
'go'
'java-environment-openjdk'
'ninja'
+ 'llvm'
'perl'
'python'
)
source=(
"https://github.com/$pkgname/envoy/archive/v$pkgver.tar.gz"
+ use_bazelisk.patch
)
-sha512sums=('1513bd07b6c8471acae85840ae1ebac2639c31b09357d854029da0d3862c5685100bc19620c2807225d69c08beb9e55ab6eaf9006c4039868968970796aa5fd8'
-)
+sha512sums=('374db0b0efb54d9ce83bf56efcaa509e46dba8624df7b91fea3e8533591f4d656250950dc358f5b22b6e770dfdc8268816dc0a0bec189f85ff00ebe803b9fe1e'
+ '248d0903c0aaa680065cdb308068e7f999f2ba7e2ffbc3b743715d2db968858f41cf104c59e1e98d6cda74baea54755e7c9edc29711c3b1daa87d63107ee4017')
prepare() {
cd "envoy-$pkgver"
- go get github.com/bazelbuild/buildtools/buildifier
- bazel --version | cut -d\ -f2 > .bazelversion
- # The commit id of $pkgver
- echo "50ef0945fa2c5da4bff7627c3abf41fdd3b7cffd" > SOURCE_VERSION
+
+ patch -Np1 -i ../use_bazelisk.patch
+
+ export GOPATH="$srcdir"/go
+
+ go get github.com/bazelbuild/bazelisk
+ export BAZELISK="$GOPATH/bin/bazelisk"
+
+ ./bazel/setup_clang.sh
}
build() {
cd "envoy-$pkgver"
- bazel build --verbose_failures --workspace_status_command bazel/get_workspace_status -c opt //source/exe:envoy-static
+ $BAZELISK build --config=clang --verbose_failures -c opt //source/exe:envoy-static
}
package() {