summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2017-10-16 14:06:30 +0000
committerBalló György2017-10-16 14:06:30 +0000
commit68cbf5a84c2d0a49caa599d1ddbfc790feec4b18 (patch)
treece7b7b1195bee1f967876e1798e69cbafb1ea6ea /PKGBUILD
parent10ce60d98422d4eae52fe2ea83699a28d19fe369 (diff)
downloadaur-68cbf5a84c2d0a49caa599d1ddbfc790feec4b18.tar.gz
upgpkg: eolie 0.9.4-1
Update to new version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 629e5f19b88c..2be687044270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,28 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
pkgname=eolie
-pkgver=0.9.0
+pkgver=0.9.4
pkgrel=1
pkgdesc="Simple web browser for GNOME"
arch=('x86_64' 'i686')
url="https://gnumdk.github.io/eolie-web/"
license=('GPL3')
depends=('gtkspell3' 'python-beautifulsoup4' 'python-cairo' 'python-gobject' 'webkit2gtk')
-makedepends=('gobject-introspection' 'intltool' 'itstool')
-source=("https://github.com/gnumdk/$pkgname/releases/download/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
- "0001-Install-webextension-into-libdir.patch")
-sha256sums=('4ad882ed899cfa88a24851443a879a1bb9f720ad3639e688c05b04ad44cb63d1'
- '3d93e35a917b8101da541e73162dcbe51889c1aa3799e058ec207d59fa6976cc')
+makedepends=('gobject-introspection' 'intltool' 'itstool' 'meson')
+source=("https://github.com/gnumdk/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('0db7d935cd102675b6ec0499b8ef876c9605059c78929b6d1973eb6b1ffe827f')
prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i ../0001-Install-webextension-into-libdir.patch
- autoreconf -fi
+ mkdir build
}
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --libexecdir=/usr/lib/$pkgname
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ cd build
+ meson --prefix=/usr --libexecdir=/usr/lib/$pkgname --buildtype=release ../$pkgname-$pkgver
+ ninja
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd build
+ DESTDIR="$pkgdir" ninja install
}