summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCédric Bellegarde2020-02-26 14:27:13 +0100
committerCédric Bellegarde2020-02-26 14:27:13 +0100
commitcd312255dfe05e9df68a4d7f2e5762969380fb02 (patch)
treebf205db806ea000443d3ca0deb1c5cec7f64ff49 /PKGBUILD
downloadaur-cd312255dfe05e9df68a4d7f2e5762969380fb02.tar.gz
Update to 0.9.97.r34.g369520f7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18e51b2f317e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=eolie-stable-git
+_gitname=eolie
+pkgver=0.9.97.r34.g369520f7
+pkgrel=1
+pkgdesc="Simple web browser for GNOME (stable branch: last release + fixes)"
+arch=('x86_64' 'i686')
+url="https://wiki.gnome.org/Apps/Eolie"
+license=('GPL3')
+depends=('gtkspell3' 'python-cairo' 'python-dateutil' 'python-gobject' 'webkit2gtk')
+makedepends=('git' 'gobject-introspection' 'meson')
+optdepends=('python-beautifulsoup4: Import html bookmarks'
+ 'python-crypto: Firefox Sync support'
+ 'python-fxa: Firefox Sync support'
+ 'python-pyopenssl: Show SSL certificates'
+ 'python-requests-hawk: Firefox Sync support')
+source=("git+https://gitlab.gnome.org/World/lollypop#branch=next")
+sha256sums=('SKIP')
+conflicts=('eolie' 'eolie-git' 'eolie-next')
+provides=("eolie=$pkgver")
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson "${_gitname}" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}