summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Gatine2017-10-17 22:47:02 +0200
committerVincent Gatine2017-10-17 22:47:02 +0200
commit24ef05026a37865b54624b7f3a5c63145330e883 (patch)
treec79da7b3388e84357db2ae78472d5dc8c577a133 /PKGBUILD
downloadaur-24ef05026a37865b54624b7f3a5c63145330e883.tar.gz
Initial PKGBUILD import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0eddde5fedd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Vincent Gatine <nurelin@nurelin.eu>
+pkgname=eovim-git
+pkgver=r202.82ef9bb
+pkgrel=1
+epoch=
+pkgdesc="EFL powered Neovim GUI"
+arch=('x86_64')
+url="https://github.com/jeanguyomarch/eovim"
+license=('MIT')
+groups=()
+depends=('efl' 'neovim' 'msgpack-c')
+makedepends=('cmake' 'git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("eovim-git::git+https://github.com/jeanguyomarch/eovim.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DCMAKE_BUILD_TYPE=Release ..
+}
+
+build() {
+ cd "$pkgname"
+ cmake --build build
+}
+
+package() {
+ cd "$pkgname"
+ cmake --build build --target install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}