summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorayekat2018-01-06 14:27:52 +0100
committerayekat2018-01-06 14:27:52 +0100
commit36422922a4f83483a6d868a00541b067a554912d (patch)
treeb8dcb8d2659065e2e3b58aa9990403c6af9676f1 /PKGBUILD
parent4d034b2151eccf2ce2719d7d8021f5b8634499df (diff)
downloadaur-36422922a4f83483a6d868a00541b067a554912d.tar.gz
Bump revision, remove changelog, improve PKGBUILD style
It's a -git package, so there is no point in keeping a changelog, as it may not properly reflect upstream anyway.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86080d60b93e..84a151d1aef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
pkgname=epfl-scripts-git
_pkgname=epfl-scripts
-pkgver=r57.82081aa
+pkgver=r59.69f6024
pkgrel=1
+
pkgdesc="Collection of scripts for simplifying one's life at EPFL"
-arch=('any')
+arch=(any)
url='https://gitlab.gnugen.ch/gnugen/epfl-scripts'
-license=('Apache')
+license=(Apache)
+
provides=(epfl-scripts)
conflicts=(epfl-scripts)
+
depends=(coreutils)
-changelog='changelog'
+
source=('git+https://gitlab.gnugen.ch/gnugen/epfl-scripts.git')
-md5sums=('SKIP')
+md5sums=(SKIP)
pkgver() {
cd "$_pkgname"
@@ -26,6 +29,7 @@ package() {
perl-www-mechanize perl-xml-xpathengine)
optdepends=('iproute2: network-namespaces in epfl-vpn'
'iptables: network-namespaces in epfl-vpn')
+
cd "$srcdir"/"$_pkgname"
install -Dm 755 bin/epfl-vpn "$pkgdir"/usr/bin/epfl-vpn
install -Dm 755 bin/gnupaste "$pkgdir"/usr/bin/gnupaste