summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLouis Tim Larsen2020-01-06 22:24:33 +0100
committerLouis Tim Larsen2020-01-06 22:24:33 +0100
commitf8652a4d40864467b97114347e5f3af6cf899d2e (patch)
treea89d1b467798e233e2cb22a52cabe79e67dcd5ad /PKGBUILD
parent2fc5e8106454ce5bf2731254e97ec6855343195c (diff)
downloadaur-f8652a4d40864467b97114347e5f3af6cf899d2e.tar.gz
Version bump to v6.1.1. Renaming of files removed which has restored default theme.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed07c92d0c50..af067a258ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,19 @@
pkgname=ephemeral-bin
_appname=ephemeral
_projectname=com.github.cassidyjames.ephemeral
-pkgver=5.2.1
-_subver=c76aa6
+pkgver=6.1.1
+_subver=5ff1cc
pkgrel=1
-pkgdesc="The always-incognito web browser. Browse the Internet in private without leaving a trace of history on your computer."
+pkgdesc="A private-by-default, always-incognito browser for elementary OS."
arch=('x86_64')
url="https://github.com/cassidyjames/ephemeral"
license=('GPL3')
depends=('dconf' 'desktop-file-utils' 'glib2>=2.49.2' 'granite>=5.2.3' 'gtk3>=3.22.29' 'hicolor-icon-theme' 'libdazzle>=3.25.3' 'libgee>=0.8.3' 'libsoup>=2.32.2' 'webkit2gtk>=2.15.4')
install=${pkgname}.install
source=("http://packages.elementary.io/appcenter/pool/main/c/${_projectname}/${_projectname}${pkgver}-${_subver}.deb")
-sha512sums=('a229bfd1f81fec9cd03a36d2ed6e4321648c65cc5db48e61de0fa9e00dc0898038159efc4351d31fba4879022971a9e46444ab47c0e92cc97ac15ac199bcb05a')
+sha512sums=('5de2937bf42ade6f93024ef8a37126e392d93426831619927b2b5198be868781e5b504d7b886f490356a88cc0a1464e500609b4c0088c4ea96a4d78a8884dd58')
package(){
-
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
-
- # Rename major files from for better system integration
- mv "${pkgdir}/usr/bin/${_projectname}" "${pkgdir}/usr/bin/${_appname}"
- mv "${pkgdir}/usr/share/applications/${_projectname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
- mv "${pkgdir}/usr/share/doc/${_projectname}" "${pkgdir}/usr/share/doc/${_appname}"
-
- # Update desktop file to match renamed package binary
- sed -i "s/Exec=${_projectname}/Exec=${_appname}/" "${pkgdir}/usr/share/applications/${_appname}.desktop"
-
}