summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2018-04-26 21:46:27 +0900
committerQue Quotion2018-04-26 21:46:27 +0900
commitd015d6264409a81f9022f37604c67c39b041b72c (patch)
tree32959e51a16144c5baeb86ebd8d28010b638ed08 /PKGBUILD
parentf27549c7a547a3d880e9aed79f5d8284cb0748b9 (diff)
downloadaur-d015d6264409a81f9022f37604c67c39b041b72c.tar.gz
Use 'arch-meson'; forget about plugins directory
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 783ce3ddcd6c..1260e6670251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=$_pkgname-pantheon-bzr
ephyver=3.27.90-1ubuntu1
ubunturel=bionic
pkgver=3.27.90.1ubuntu1.r20
-pkgrel=1
+pkgrel=2
pkgdesc="A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches"
url="http://www.gnome.org/projects/epiphany/"
arch=('i686' 'x86_64')
@@ -19,7 +19,6 @@ replaces=(epiphany)
provides=(epiphany epiphany-sync)
conflicts=(epiphany)
source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-${ubunturel}"
- "pluginsdir.diff"
epiphany-sync{,.service})
sha256sums=('SKIP'
'3e648118d7d45fc1cce04d45c7443ed0cc54e3a65aefcb4fb12ce5e01014c53e'
@@ -32,17 +31,10 @@ pkgver() {
echo "${ephyver/-/.}.r$(bzr revno)"
}
-prepare() {
- cd "os-patch-epiphany-browser-${ubunturel}"
-
- msg2 "Plugins Directory"
- #patch -Np1 < ../pluginsdir.diff
-}
-
build() {
cd "os-patch-epiphany-browser-${ubunturel}"
[ -d build ] && rm -rf build
- meson build --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/"${_pkgname}" --buildtype=release -Denable_https_everywhere=true
+ arch-meson build -Denable_https_everywhere=true
ninja -C build
}