summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2018-03-14 03:00:46 +0900
committerQue Quotion2018-03-14 03:00:46 +0900
commitfe4f7734571331717b4059ce302f7fe5cb6d0087 (patch)
treedc9906253d05d1f54823695d561f616957d9f117 /PKGBUILD
parent7b37f21aabb9a195d48abc2f5774d99a3d87fe07 (diff)
downloadaur-fe4f7734571331717b4059ce302f7fe5cb6d0087.tar.gz
Include epiphany-sync: Synchronize browser profile to shared memory for faster loading
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48e9a374f635..d86c5cca49be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=$_pkgname-pantheon-bzr
ephyver=3.27.90-1ubuntu1
ubunturel=bionic
pkgver=3.27.90.1ubuntu1.r19
-pkgrel=1
+pkgrel=2
pkgdesc="A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches"
url="http://www.gnome.org/projects/epiphany/"
arch=('i686' 'x86_64')
@@ -16,34 +16,39 @@ makedepends=(meson docbook-xml startup-notification lsb-release
gobject-introspection yelp-tools autoconf-archive appstream-glib git)
groups=(pantheon-unstable pantheon-qq)
replaces=(epiphany)
-provides=(epiphany)
+provides=(epiphany epiphany-sync)
conflicts=(epiphany)
-source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-$ubunturel"
- "pluginsdir.diff")
+source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-${ubunturel}"
+ "pluginsdir.diff"
+ epiphany-sync{,.service})
sha256sums=('SKIP'
- '3e648118d7d45fc1cce04d45c7443ed0cc54e3a65aefcb4fb12ce5e01014c53e')
+ '3e648118d7d45fc1cce04d45c7443ed0cc54e3a65aefcb4fb12ce5e01014c53e'
+ 'bb8c06dadcba9c9f0ba887dc0a65283c26282f7db75c22dade209fcaa6f72f72'
+ 'ce1ac321d7bf9d88638634a141dfcb99119fc59ee44c4892e0874608e85006ba')
pkgver() {
- cd "os-patch-epiphany-browser-$ubunturel"
+ cd "os-patch-epiphany-browser-${ubunturel}"
echo "${ephyver/-/.}.r$(bzr revno)"
}
prepare() {
- cd "os-patch-epiphany-browser-$ubunturel"
+ cd "os-patch-epiphany-browser-${ubunturel}"
msg2 "Plugins Directory"
#patch -Np1 < ../pluginsdir.diff
}
build() {
- cd "os-patch-epiphany-browser-$ubunturel"
+ cd "os-patch-epiphany-browser-${ubunturel}"
[ -d build ] && rm -rf build
- meson build --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$_pkgname --buildtype=release -Denable_https_everywhere=true
+ meson build --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/"${_pkgname}" --buildtype=release -Denable_https_everywhere=true
ninja -C build
}
package() {
cd "os-patch-epiphany-browser-$ubunturel"
- DESTDIR=${pkgdir} ninja -C build install
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/bin}/epiphany-sync
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/epiphany-sync.service
}