summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlorenzo2017-08-25 15:25:55 +0200
committerlorenzo2017-08-25 15:25:55 +0200
commitba31542650937127c57612fef26299f705ca3447 (patch)
tree3ccc77248cde5b26ac24c426d3411863412d367a /PKGBUILD
downloadaur-ba31542650937127c57612fef26299f705ca3447.tar.gz
Updated to 0.7.0, use python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2534b263f77f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=epour
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Torrent client based on EFL"
+arch=('any')
+url="https://phab.enlightenment.org/w/projects/epour/"
+license=('GPL3')
+depends=('python-efl' 'python-xdg' 'libtorrent-rasterbar>1.1.0' 'hicolor-icon-theme')
+makedepends=('python-distutils-extra')
+source=("http://download.enlightenment.org/rel/apps/$pkgname/$pkgname-$pkgver.tar.xz")
+sha1sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py install --root="${pkgdir}" #--optimize=1 if this active epour doesn't show icons
+
+# install text files
+ install -d "$pkgdir/usr/share/doc/$pkgname/"
+ install -m644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README COPYING
+}