summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDennis van der Schagt2020-08-26 22:25:03 +0200
committerDennis van der Schagt2020-08-26 22:25:03 +0200
commit5153b28ad017fe61ededba7e7b5707f3aaa5566a (patch)
tree682da2e8c9c55f4a2bc3404eacf00d9caea01e8b /PKGBUILD
downloadaur-5153b28ad017fe61ededba7e7b5707f3aaa5566a.tar.gz
Add PKGBUILD for eProsima's Fast-DDS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc3f12bb500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
+pkgname=eprosima-fast-dds
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="eProsima's Fast-DDS implementation"
+arch=('x86_64')
+url="https://github.com/eProsima/Fast-DDS"
+license=('Apache')
+depends=('asio' 'tinyxml2' 'foonathan_memory-shared')
+makedepends=('cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('d557425232da27c84b6142b17cdbccd3076233b445762a5f232205ecf5fff6ab')
+validpgpkeys=()
+
+build() {
+ cd "Fast-DDS-$pkgver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make -C build
+}
+
+package() {
+ cd "Fast-DDS-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
+}