summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkistlin2023-05-12 21:59:33 +0200
committerkistlin2023-05-12 21:59:33 +0200
commitb498025e94151c034203692da48f7a93ccfbf3dd (patch)
tree5b1c802f5a9e6dc2a3ba7fc49363c55eef27d337 /PKGBUILD
parent03aa29ec03709400d05812684dcd167b0bbc91d0 (diff)
downloadaur-b498025e94151c034203692da48f7a93ccfbf3dd.tar.gz
fix build issues with GCC 13.1+
upstream issue created: https://github.com/eProsima/Fast-DDS/issues/3514
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 947aefb5e6a0..b04574d65dd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
pkgname=eprosima-fast-dds
pkgver=2.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="eProsima's Fast-DDS implementation"
arch=('x86_64')
url="https://github.com/eProsima/Fast-DDS"
@@ -17,17 +17,28 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
+source=(
+ "https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz"
+ "001-gcc-13-1.patch"
+)
noextract=()
-sha256sums=('2cc2682db5dc7e87684b7f23166e2f32faf8d5c4b4a8c94c6c21211a8a38f553')
+sha256sums=(
+ '2cc2682db5dc7e87684b7f23166e2f32faf8d5c4b4a8c94c6c21211a8a38f553'
+ 'd4e29cda89334ddadd6d619a18dfdfaaee184cd7df7ad09c2de1e2673b2a36cb'
+)
validpgpkeys=()
+prepare() {
+ cd Fast-DDS-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/001-gcc-13-1.patch"
+}
+
build() {
cd "Fast-DDS-$pkgver"
cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
.
- make -C build -j8
+ cmake --build build --parallel 8
}
package() {