summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexej Magura2020-04-27 13:00:35 -0600
committerAlexej Magura2020-04-27 13:00:35 -0600
commit9cc2533886997d5ad023578c25d8e20a2fdd3c3c (patch)
tree8974f75fb6fe678378aa5b037d144844744a474c /PKGBUILD
parentde9b6d0ad7ca2f3efba758dd7829422d43fc51ca (diff)
downloadaur-9cc2533886997d5ad023578c25d8e20a2fdd3c3c.tar.gz
major update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 31 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e653fb3fb52..adf203e5a95b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,54 @@
#
-# Maintainer: Alexej Magura <agm2819*gmail*>
+# Maintainer: Alexej Magura <sickhadas.code at gmail dot com>
# Contributor: Swen Simon <swsimon at gmail dot com>
# Contributor: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
#
-# XXX maybe bin32 should be combined with this and we should use pkgbase?
pkgname=epsxe
_pkgname=ePSXe
pkgver=2.0.5
-pkgrel=23
-pkgdesc="Enhanced PSX emulator (64-bit)"
+pkgrel=24
+pkgdesc="Enhanced PSX emulator"
url="http://epsxe.com"
-arch=('x86_64')
-depends=(gtk3
- libxt
- sdl_ttf
- libcurl-compat
- libcanberra
- bash
- 'ncurses>=6.0+20170902-2'
- openssl-1.0
- ncurses5-compat-libs
- )
+arch=('i686' 'x86_64')
+depends=(bash libcurl-compat gtk3 sdl_ttf ncurses openssl-1.0)
+depends_x86_64=(libxt libcanberra)
license=('unknown')
install=${pkgname}.install
options=(!strip)
-source=(${pkgname}.desktop
- ${pkgname}.png
- ${pkgname}.sh
- "http://www.epsxe.com/files/${_pkgname}${pkgver//./}linux_x64.zip"
- )
-md5sums=('aeb34e2ca34f968630ca133ea821c61c'
- 'eb0c46b8ae1355c589792f6be1835e47'
- '8d47875ba4f51943cdb6e09c2f25e4b5'
- '79fefeb4bff26bf1d374befb35b390df'
- )
+replaces=(bin32-epsxe)
+source=(${pkgname}.desktop ${pkgname}.png ${pkgname}.sh)
+md5sums=(aeb34e2ca34f968630ca133ea821c61c eb0c46b8ae1355c589792f6be1835e47 8d47875ba4f51943cdb6e09c2f25e4b5)
-package()
+if [[ $CARCH =~ 'x' ]]; then
+ source+=("http://www.epsxe.com/files/${_pkgname}${pkgver//./}linux_x64.zip")
+ md5sums+=(79fefeb4bff26bf1d374befb35b390df)
+else
+ source+=("http://www.epsxe.com/files/${_pkgname}${pkgver//./}linux.zip")
+ md5sums+=(3e1976822eb260722b31c9f24cb1d6e1)
+fi
+
+prepare()
{
- _binary="${pkgname}_x64"
+ cd "$srcdir"
+ mv "${pkgname}_x64" "$pkgname" 2> /dev/null || true
+}
- cd "${srcdir}"
+package()
+{
+ cd "$srcdir"
install -d "${pkgdir}"/usr/{share/doc/"${pkgname}",lib}
- find docs -name 'e???e_*.txt' -execdir install -m 644 -t ${pkgdir}/usr/share/doc/${pkgname} \{\} +
+ find docs -name 'e???e_*.txt' -execdir install -m 644 -t $pkgdir/usr/share/doc/$pkgname \{\} +
- install -Dm 755 "${_binary}" "${pkgdir}/opt/${pkgname}/${pkgname}"
+ install -Dm 755 "$pkgname" "$pkgdir/opt/$pkgname/$pkgname"
- cd "${srcdir}"
+ cd "$srcdir"
install -Dm 755 ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
- install -Dm 644 "${srcdir}/epsxe.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm 644 "${srcdir}/epsxe.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 644 "$srcdir/epsxe.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "$srcdir/epsxe.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
ln -sf "$HOME/.${pkgname}rc" -T "${pkgdir}/opt/${pkgname}/.${pkgname}rc"
+ ln -sf /usr/lib/libncursesw.so "$pkgdir"/opt/$pkgname/libncurses.so.5
+ ln -sf /usr/lib/libncursesw.so "$pkgdir"/opt/$pkgname/libtinfo.so.5
}