summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoramagura2016-05-22 18:20:50 -0600
committeramagura2016-05-22 18:20:50 -0600
commitcf75b54bf18ce40e0a590267819b74a67748f319 (patch)
treebb4d783345d8bbb321a100cdfcc3f63c99a105a1 /PKGBUILD
parent50f8ba30595ebb648343aaed7ac94a3a2964351a (diff)
downloadaur-cf75b54bf18ce40e0a590267819b74a67748f319.tar.gz
committed patch from @rdoursenaud--had to change some things, but mostly left intact.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 24 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83bcb3695335..68d8b43fa604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Maintainer: Alexej Magura <agm2819*gmail*>
# Contributor: Swen Simon <swsimon at gmail dot com>
+# Contributor: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
#
pkgname=epsxe
+_pkgname=ePSXe
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Enhanced PSX emulator"
url="http://epsxe.com"
arch=('i686' 'x86_64')
+#depends=(gtk2 sdl_ttf ncurses5-compat-libs libtinfo-5 libcurl-compat)
depends_i686+=(gtk2 sdl_ttf libtinfo)
depends_x86_64+=(lib32-gtk2 lib32-ncurses lib32-libxt lib32-sdl_ttf lib32-alsa-lib lib32-libtinfo)
license=('unknown')
@@ -23,28 +26,30 @@ else
source+=("http://www.epsxe.com/files/ePSXe${pkgver//./}linux.zip")
md5sums+=('787826ee6b0f95ea2df511dd7fd29abd')
fi
-_ncurses="$(pacman -Q ncurses | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
-_lib32_ncurses="$(pacman -Q lib32-ncurses | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
package () {
- cd "$srcdir"
- install -m775 -g games -d "$pkgdir/opt/$pkgname/"{plugins,bios,memcards,cfg,cdimages,cheats,patches,sstates,snap}
- install -d "$pkgdir"/usr/{share/doc/"$pkgname",lib}
+ srcpath="${srcdir}/${_pkgname}${pkgver//./}linux"
+ binary="${pkgname}"
+ if [[ $CARCH == "x86_64" ]]; then
+ srcpath+="_x64"
+ binary+="_x64"
+ fi
- find docs -name 'e???e_*.txt' -execdir install -m 644 -t $pkgdir/usr/share/doc/$pkgname \{\} +
- # find . -name '*.cht' -execdir "install -Dm 644 -t \$pkgdir/opt/$pkgname/$pkgver/cheats\"" \{\} +
+ cd "${srcpath}"
+# install -m775 -g games -d "${pkgdir}/opt/${pkgname}/"{plugins,bios,memcards,cfg,cdimages,cheats,patches,sstates,snap}
+ install -d "${pkgdir}"/usr/{share/doc/"${pkgname}",lib}
- install -Dm 755 ${pkgname} "$pkgdir/opt/$pkgname/$pkgname"
- install -Dm 644 keycodes.lst "$pkgdir/opt/$pkgname/keycodes.lst"
+ find docs -name 'e???e_*.txt' -execdir install -m 644 -t ${pkgdir}/usr/share/doc/${pkgname} \{\} +
+ # find . -name '*.cht' -execdir "install -Dm 644 -t \${pkgdir}/opt/${pkgname}/${pkgver}/cheats\"" \{\} +
- install -Dm 755 ${pkgname}.sh "$pkgdir/usr/bin/$pkgname"
- install -Dm 644 "$srcdir/epsxe.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
- install -Dm 644 "$srcdir/epsxe.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
- ln -sf "$HOME/.${pkgname}rc" -T "$pkgdir/opt/$pkgname/.${pkgname}rc"
- case "$CARCH" in
- ('x86_64') ln -s /usr/lib32/libncursesw.so."${_lib32_ncurses}" "$pkgdir"/opt/$pkgname/libncurses.so.5;
- ln -s /usr/lib32/libtinfo.so "$pkgdir"/opt/$pkgname/libtinfo.so.5;;
- ('i686') ln -s /usr/lib/libncursesw.so."${_ncurses}" "$pkgdir"/opt/$pkgname/libncurses.so.5;;
- esac
+ install -Dm 755 "${binary}" "${pkgdir}/opt/${pkgname}/${pkgname}"
+# install -Dm 644 keycodes.lst "${pkgdir}/opt/${pkgname}/keycodes.lst"
+
+ cd "${srcdir}"
+ install -Dm 755 ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 "${srcdir}/epsxe.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm 644 "${srcdir}/epsxe.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ ln -sf "$HOME/.${pkgname}rc" -T "${pkgdir}/opt/${pkgname}/.${pkgname}rc"
}