summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2014-08-01 09:17:22 -0500
committerDoug Newgard2014-08-01 09:17:22 -0500
commit09315f5aa791fc95620e3d3a81d1b788beb72e39 (patch)
tree2a009bb591b87c05d12eb255329d7b7e455264c4 /PKGBUILD
downloadaur-09315f5aa791fc95620e3d3a81d1b788beb72e39.tar.gz
Initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..885c2275177a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=epymc
+_pkgver=1.0.0-beta1
+pkgver=1.0.0beta1
+pkgrel=1
+pkgdesc="Media Center based on EFL"
+arch=('any')
+url="https://github.com/DaveMDS/epymc"
+license=('GPL3')
+depends=('python2-efl')
+optdepends=('mutagen: music module'
+ 'lirc: remote contol support'
+ 'sdlmame: MAME module')
+source=("https://github.com/DaveMDS/$pkgname/archive/v$_pkgver.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$_pkgver"
+
+ find -name "*.py" -exec sed -i 's/env python$/&2/' {} \;
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}