summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2014-08-01 09:16:56 -0500
committerDoug Newgard2014-08-01 09:16:56 -0500
commit60743a9c101b8d4143a4be87a2f5e8ae3707c78a (patch)
tree2026c888370c6bed2e6a11dc6a4ab512691ff49b /PKGBUILD
downloadaur-60743a9c101b8d4143a4be87a2f5e8ae3707c78a.tar.gz
Initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9531c3ed73b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+
+_pkgname=epymc
+pkgname=$_pkgname-git
+pkgver=1.0.0beta1.r1.ge213b2b
+pkgrel=1
+pkgdesc="Media Center based on EFL - Development version"
+arch=('any')
+url="https://github.com/DaveMDS/epymc"
+license=('GPL3')
+depends=('python2-efl')
+optdepends=('mutagen: music module'
+ 'lirc: remote contol support'
+ 'sdlmame: MAME module')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("git://github.com/DaveMDS/epymc.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ git describe --tags --long | sed 's/^v//;s/-beta/beta/;s/-/.r/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ find -name "*.py" -exec sed -i 's/env python$/&2/' {} \;
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}