summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-11-09 08:53:06 +0100
committerAlexander F. Rødseth2021-11-09 08:53:06 +0100
commit39d8b42c0045d35fc0dc7304b7013996cf3cf7cb (patch)
tree7fd867be1334aabe23ddfe4edacf026c65b168a5 /PKGBUILD
downloadaur-erlang-sdl.tar.gz
Add erlang-sdl. Needed by wings3d. Currently does not compile.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98be764dbb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: kappa <kappacurve@gmail.com>
+
+pkgname=erlang-sdl
+pkgver=1.3.1
+pkgrel=4
+arch=('x86_64')
+pkgdesc='SDL and OpenGL bindings for Erlang'
+url='https://github.com/dgud/esdl/'
+license=(custom)
+depends=(erlang glu libgl sdl)
+makedepends=(git mesa-libgl rebar)
+#tag=esdl-1.3.1 fails
+source=("esdl::git+$url#commit=dbd8ce9228aa")
+md5sums=('SKIP')
+
+prepare() {
+ find esdl -type f -exec chmod 644 {} \;
+}
+
+build() {
+ cd esdl
+ CFLAGS="$CFLAGS -Wno-deprecated-declarations" rebar compile
+}
+
+package() {
+ cd esdl
+ install -d "$pkgdir/usr/lib/erlang/lib/esdl-$pkgver"
+ cp -ruv c_src doc ebin include priv src \
+ "$pkgdir/usr/lib/erlang/lib/esdl-$pkgver/"
+ install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}