summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorX3n0m0rph592019-11-29 09:22:25 +0100
committerX3n0m0rph592019-11-29 09:22:25 +0100
commit404bf10b516919b98a641d747fd805646605530a (patch)
tree18a3442b07b8c0a46db175ca413f895c36e45880 /PKGBUILD
parent011738a6a00e103797c7462399fd6bdbbe70c96e (diff)
downloadaur-404bf10b516919b98a641d747fd805646605530a.tar.gz
Trigger Rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 59 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd86c6c53be7..1fdf0d3d32e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname='eruption-roccat-vulcan-git'
_pkgname='eruption-roccat-vulcan'
pkgdesc='Linux user-mode driver for the ROCCAT Vulcan 100/12x series keyboards'
pkgver='0.0.9'
-pkgrel='4'
+pkgrel='5'
epoch=
arch=('i686' 'x86_64')
url='https://x3n0m0rph59.gitlab.io/eruption-roccat-vulcan/'
@@ -38,7 +38,6 @@ package() {
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/etc/eruption"
mkdir -p "$pkgdir/usr/share/doc/eruption"
- mkdir -p "$pkgdir/usr/share/eruption/templates"
mkdir -p "$pkgdir/usr/lib/eruption/scripts"
mkdir -p "$pkgdir/usr/lib/eruption/scripts/lib"
@@ -90,10 +89,68 @@ package() {
install -m 644 "src/scripts/temperature.lua" "$pkgdir/usr/lib/eruption/scripts/"
install -m 644 "src/scripts/temperature.lua.manifest" "$pkgdir/usr/lib/eruption/scripts/"
+ # Web-Frontend
+ mkdir -p "$pkgdir/usr/share/eruption/templates"
+ mkdir -p "$pkgdir/usr/share/eruption/static/{css,js,font,img}"
+
install -m 644 "templates/about.html.tera" "$pkgdir/usr/share/eruption/templates/"
install -m 644 "templates/base.html.tera" "$pkgdir/usr/share/eruption/templates/"
install -m 644 "templates/detail.html.tera" "$pkgdir/usr/share/eruption/templates/"
install -m 644 "templates/documentation.html.tera" "$pkgdir/usr/share/eruption/templates/"
install -m 644 "templates/profiles.html.tera" "$pkgdir/usr/share/eruption/templates/"
install -m 644 "templates/settings.html.tera" "$pkgdir/usr/share/eruption/templates/"
+
+ install -m 644 "static/css/animate.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/style.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/themes/eruption/colors.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/themes/metal/colors.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap.min.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap.min.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-grid.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-grid.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-grid.min.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-grid.min.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-reboot.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-reboot.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-reboot.min.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/bootstrap-reboot.min.css.map" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/css/fontawesome.min.css" "$pkgdir/usr/share/eruption/static/css/"
+ install -m 644 "static/font/fa-brands-400.eot" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-brands-400.svg" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-brands-400.ttf" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-brands-400.woff" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-brands-400.woff2" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-regular-400.eot" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-regular-400.svg" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-regular-400.ttf" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-regular-400.woff" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-regular-400.woff2" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-solid-900.eot" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-solid-900.svg" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-solid-900.ttf" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-solid-900.woff" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/fa-solid-900.woff2" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/Roboto-Regular.ttf" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/CuteFont-Regular.ttf" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/Roboto-Regular.woff2" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/font/CuteFont-Regular.woff2" "$pkgdir/usr/share/eruption/static/font/"
+ install -m 644 "static/img/bg_direction_nav.png" "$pkgdir/usr/share/eruption/static/img/"
+ install -m 644 "static/img/glyphicons-halflings.png" "$pkgdir/usr/share/eruption/static/img/"
+ install -m 644 "static/img/bg/bg-1.jpg" "$pkgdir/usr/share/eruption/static/img/"
+ install -m 644 "static/img/icons/eruption.png" "$pkgdir/usr/share/eruption/static/img/"
+ install -m 644 "static/img/favicon.png" "$pkgdir/usr/share/eruption/static/img/"
+ install -m 644 "static/js/animate.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/custom.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.bundle.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.bundle.js.map" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.bundle.min.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.bundle.min.js.map" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.js.map" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.min.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/bootstrap.min.js.map" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/jquery.js" "$pkgdir/usr/share/eruption/static/js/"
+ install -m 644 "static/js/fontawesome.min.js" "$pkgdir/usr/share/eruption/static/js/"
}