summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-10-12 15:14:48 +0200
committerSefa Eyeoglu2019-10-12 15:14:48 +0200
commit709ccbe31431dd949b60da2a574a5f8f93458d62 (patch)
tree316ef884d13240ee5febc068c8a840bf9345bd81 /PKGBUILD
parent21fec5b03cea95c64e62c7d19ada0d78b00dbb5b (diff)
downloadaur-709ccbe31431dd949b60da2a574a5f8f93458d62.tar.gz
upgpkg: espanso-git v0.2.4.r15.gf277558-1
Update to v0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 617739b07e9b..aa2f4ab17b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+_branch=dev
_pkgname=espanso
pkgname=${_pkgname}-git
-pkgver=v0.2.4.r0.g7d3a017
+pkgver=v0.2.4.r15.gf277558
pkgrel=1
pkgdesc="Cross-platform Text Expander written in Rust"
arch=(x86_64)
@@ -13,10 +14,8 @@ makedepends=("rust" "git")
provides=($_pkgname)
conflicts=($_pkgname)
install="${pkgname}.install"
-source=("${_pkgname}::git+https://github.com/federico-terzi/espanso.git"
- "service")
-sha512sums=('SKIP'
- '5eb7b751e9432c7dde71da1f0c8c459b33a6a15d3a81aa21cbaa251b7b2cdddc47da9a0ab22215a9fb063ecdd8123c86c8f96459e627fd6daff4e690ff1a6df2')
+source=("${_pkgname}::git+https://github.com/federico-terzi/espanso.git#branch=${_branch}")
+sha512sums=('SKIP')
pkgver() {
@@ -25,10 +24,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-check() {
+prepare() {
cd "$_pkgname"
- cargo test --release --locked
+ # don't change the original service file, as it will be embedded in the binary
+ cp "src/res/linux/systemd.service" "systemd.service"
+ sed -i "s|{{{espanso_path}}}|/usr/bin/espanso|g" "systemd.service"
}
build() {
@@ -41,7 +42,7 @@ package() {
cd "$_pkgname"
install -Dm755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "../service" "${pkgdir}/usr/lib/systemd/user/${_pkgname}.service"
+ install -Dm644 "systemd.service" "${pkgdir}/usr/lib/systemd/user/${_pkgname}.service"
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
}