summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergio Garnica2019-02-27 08:44:43 +0100
committerSergio Garnica2019-02-27 08:44:43 +0100
commit0a3ee0a2b30b1869309941490e7c0ad343630fb2 (patch)
tree7e8ff91055d6ad42cc0fee8e0fa790e82d760941 /PKGBUILD
parent8c2db94d4e88da7d822b518f2472cfa3fec5f38e (diff)
downloadaur-0a3ee0a2b30b1869309941490e7c0ad343630fb2.tar.gz
Upgrade v. 1.11.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9f7763eee5f..c4bc74aa6301 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Mantainer: S garnica < swhaat at github >
-pkgname=esphomeyaml
-_base=ESPHome
-pkgver=1.10.1
+pkgname=esphome
+pkgver=1.11.1
pkgrel=1
pkgdesc="Solution for your ESP8266/ESP32 projects with Home Assistant"
url="https://github.com/esphome/ESPHome"
@@ -15,27 +14,30 @@ depends=('python-setuptools'
'python-protobuf'
'python-tzlocal'
'python-pyserial'
+ 'python-ifaddr'
'platformio-git'
'esptool-git')
license=('MIT')
arch=('any')
+replaces=('esphomeyaml')
source=("https://github.com/esphome/ESPHome/archive/v${pkgver}.tar.gz")
-md5sums=('19d511002b9774d10dde60e7ed3b7a94')
+md5sums=('4309a8d45855bf7f0726ff8e76b8905d')
build() {
- cd "$srcdir/${_base}-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/${_base}-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
check() {
- cd "$srcdir/${_base}-${pkgver}"
- cp esphomeyaml/__main__.py esphomeyaml.py
+ cd "$srcdir/${pkgname}-${pkgver}"
+
## Run tests, takes a while
+# cp ${pkgname}/__main__.py ${pkgname}.py
# python esphomeyaml.py tests/test1.yaml compile
# python esphomeyaml.py tests/test2.yaml compile
}