summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorS Garnica2019-11-02 11:00:58 +0100
committerS Garnica2019-11-02 11:00:58 +0100
commit955b364817e2e05370d71bb1cb241dbffead951e (patch)
tree8e2ff0482c2c8bdc060ea9760c016f6d268c71d4 /PKGBUILD
parent3023295e32376902c35bf60edc0310f3203a3fe3 (diff)
downloadaur-955b364817e2e05370d71bb1cb241dbffead951e.tar.gz
Update v1.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bb9235f8ad4..27c06b21bc4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgbase=esphomeyaml
pkgname=esphome
-pkgver=1.13.6
-pkgrel=2
+pkgver=1.14.0
+pkgrel=1
pkgdesc="Solution for your ESP8266/ESP32 projects with Home Assistant"
url="https://github.com/esphome/ESPHome"
depends=('python-setuptools'
'python-voluptuous'
- 'python-yaml>=5.1'
+ 'python-yaml'
'python-paho-mqtt'
- 'python-colorlog>=4.0.2'
+ 'python-colorlog'
'python-tornado'
'python-protobuf'
'python-tzlocal'
@@ -19,12 +19,12 @@ depends=('python-setuptools'
'python-pyaes'
'python-ecdsa'
'platformio'
- 'esptool-git')
+ 'esptool')
license=('MIT')
arch=('any')
replaces=('esphomeyaml')
source=("https://github.com/esphome/ESPHome/archive/v${pkgver}.tar.gz")
-sha256sums=('c9ffef72555e895fd14178f10a1195e39a90b1eb1ead51cc1c33781eb0958f27')
+sha256sums=('e50a4880b6e2a4c37e9abe3156f0f4c12aa16b1a37a05f2bc7868329bb450114')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -40,8 +40,8 @@ check() {
cd "$srcdir/${pkgname}-${pkgver}"
## Run tests, takes a while
-# cp ${pkgname}/__main__.py ${pkgname}.py
-# python esphome.py tests/test1.yaml compile
+ cp ${pkgname}/__main__.py ${pkgname}.py
+ python esphome.py tests/test1.yaml compile
# python esphome.py tests/test2.yaml compile
}