summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorObscurely2022-12-11 08:05:50 +0200
committerObscurely2022-12-11 08:05:50 +0200
commit88cc08cfe2f487252a01fa4c5e92b9e96d7c3c46 (patch)
tree045ed44d7c073f3d2c68fd792a2be1e7a8c24a37 /PKGBUILD
parentdbf0ad9bd9d9f5448799b5f579cb8363b73f745c (diff)
downloadaur-88cc08cfe2f487252a01fa4c5e92b9e96d7c3c46.tar.gz
add desktop files
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f013f047990f..e2a300a56661 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
pkgname=estash
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
url="https://github.com/Obscurely/EStash"
@@ -31,4 +31,9 @@ package() {
cd "$srcdir/EStash-$pkgver-stable"
install -Dm 755 "target/release/estash" -t "$pkgdir/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "linux/desktop/EStash.desktop"
+ for size in 16x16 24x24 32x32 48x48 64x64 128x128 256x256; do
+ install -Dm0644 "linux/desktop/icons/hicolor/$size/apps/estash.png" \
+ "$pkgdir/usr/share/icons/hicolor/$size/apps/estash.png"
+ done
}