summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorObscurely2022-12-10 19:39:39 +0200
committerObscurely2022-12-10 19:39:39 +0200
commit9a127e03791d775f218dba1922596ee2a3e2fec1 (patch)
tree542bc354f8307d05bf1004323100d33763f04e91 /PKGBUILD
parentc03bb731ecbfa223825435750239047f5643d60e (diff)
downloadaur-9a127e03791d775f218dba1922596ee2a3e2fec1.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a701cd80093..d3bfa3e1a46d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,34 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
-pkgname=estash-bin
+pkgname=estash
pkgver=0.5.1
pkgrel=1
-epoch=
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
url="https://github.com/Obscurely/EStash"
license=('GPL3')
-provides=('estash-bin')
-conflicts=('estash' 'estash-git')
-source=("https://github.com/Obscurely/EStash/releases/download/v${pkgver}-stable/estash-linux.tar.gz")
-sha256sums=("c96129830a0f1cebae66ec49375b926f86d39f00cefcc9fc11e3bb7b21f2886f")
+makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver-stable.tar.gz")
+sha256sums=('SKIP')
-package() {
- cd "$srcdir/"
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
- install -Dm755 dym -t "${pkgdir}/usr/bin/"
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-bin}/"
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --frozen --lib
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/estash" -t "$pkgdir/usr/bin"
+ install -Dm 644 docs/README.md -t "$pkgdir/usr/share/doc/$pkgname"
}