summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorObscurely2022-12-10 19:16:36 +0200
committerObscurely2022-12-10 19:16:36 +0200
commitc03bb731ecbfa223825435750239047f5643d60e (patch)
treec91954ad842169bbb385bf7d93925ab8aa3c89f6 /PKGBUILD
parentd9e8e52c0a46acf95c844ef2812f24dd46f30224 (diff)
downloadaur-c03bb731ecbfa223825435750239047f5643d60e.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD36
1 files changed, 11 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29f020f80039..5a701cd80093 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,20 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
-pkgname=estash
-pkgver=0.0.0
+pkgname=estash-bin
+pkgver=0.5.1
pkgrel=1
+epoch=
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
url="https://github.com/Obscurely/EStash"
license=('GPL3')
-makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('SKIP')
-
-prepare() {
- cd "$pkgname-$pkgver"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
-}
-
-build() {
- cd "$pkgname-$pkgver"
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo build --release --frozen
-}
-
-check() {
- cd "$pkgname-$pkgver"
- cargo test --frozen --lib
-}
+provides=('estash-bin')
+conflicts=('estash' 'estash-git')
+source=("https://github.com/Obscurely/EStash/releases/download/v${pkgver}-stable/estash-linux.tar.gz")
+sha256sums=("c96129830a0f1cebae66ec49375b926f86d39f00cefcc9fc11e3bb7b21f2886f")
package() {
- cd "$pkgname-$pkgver"
- install -Dm 755 "target/release/dym" -t "$pkgdir/usr/bin"
- install -Dm 644 docs/README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cd "$srcdir/"
+
+ install -Dm755 dym -t "${pkgdir}/usr/bin/"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-bin}/"
}