summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorObscurely2022-12-10 19:15:18 +0200
committerObscurely2022-12-10 19:15:18 +0200
commitd9e8e52c0a46acf95c844ef2812f24dd46f30224 (patch)
treee57ae1b55bfd930a3dc7240cda242f409753ce08 /PKGBUILD
downloadaur-d9e8e52c0a46acf95c844ef2812f24dd46f30224.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..29f020f80039
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
+pkgname=estash
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
+arch=('x86_64')
+url="https://github.com/Obscurely/EStash"
+license=('GPL3')
+makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --frozen --lib
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/dym" -t "$pkgdir/usr/bin"
+ install -Dm 644 docs/README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}