summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2021-11-08 02:02:21 +0100
committerml2021-11-08 02:02:21 +0100
commitd355257426fe33864881b78b746a0939f44bbe6e (patch)
treed7d4f2f050a85f5bc358be5944eb23f531ec36dc /PKGBUILD
parenta1c40f04f4361d761b7f4b02371deebfef113cf3 (diff)
downloadaur-d355257426fe33864881b78b746a0939f44bbe6e.tar.gz
updpkg: etcdadm 0.1.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36ffa49dd1cc..06b8bdf977b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <ml@visu.li>
pkgname=etcdadm
-pkgver=0.1.3
+pkgver=0.1.5
pkgrel=1
pkgdesc='Commandline tool for operating an etcd cluster'
arch=('x86_64')
@@ -9,12 +9,7 @@ license=('Apache')
depends=('glibc')
makedepends=('git' 'go')
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('0c2ae4401c6fe1c85d672e6f991c7e178ec7625ae2da27cf889174d1c7953e14')
-
-prepare() {
- cd "$pkgname-$pkgver"
- go mod download
-}
+sha256sums=('ad5a828d09e154b745fce0cd74d0257f61307ed4323a54272d3e2512d5a37eb9')
build() {
local _commit='' _ver=${pkgver%.?}
@@ -34,8 +29,8 @@ build() {
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- go build -o "$pkgname" -ldflags "${_x[*]/#/-X=k8s.io/component-base/version.}"
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw'
+ go build -o "$pkgname" -ldflags "-linkmode=external ${_x[*]/#/-X=k8s.io/component-base/version.}" main.go
}
package() {