summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Stubbs2016-06-16 10:03:40 +0100
committerAndrew Stubbs2016-06-16 10:03:40 +0100
commit3152863477507bf538faa96647016b63b3a84ce8 (patch)
tree65aa3276c05890bb1364ced8779d182e2c4cf9d0 /PKGBUILD
parent79c82847670ec8559e42d25fc347c7576b3663ed (diff)
downloadaur-3152863477507bf538faa96647016b63b3a84ce8.tar.gz
fix bugs in non-clean builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffac0390ab40..568a2ee436aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,22 @@ license=('apache')
source=("etcher"
"Etcher.desktop"
"etcher.png")
-source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x86.AppImage")
-source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x64.AppImage")
-noextract=("Etcher-linux-x64.AppImage")
+source_i686=("Etcher-linux-x86-$realver.AppImage::https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x86.AppImage")
+source_x86_64=("Etcher-linux-x64-$realver.AppImage::https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x64.AppImage")
+noextract=("Etcher-linux-x86-$realver.AppImage" "Etcher-linux-x64-$realver.AppImage")
options=("!strip")
md5sums=('8eff5560a3a4cae73698d7eda2d71577'
'89f5cf77f164510b1f980820aaa4cf91'
'7bd70ef05c6293e36938240be2558091')
-md5sums_i686=('1118cf594b3eaee866ed246a8c0f38b5')
-md5sums_x86_64=('7f1da299a708d27d7f6b77cc1900ed6d')
+md5sums_i686=('7260c5837d4a1e55a22836cd91025f21')
+md5sums_x86_64=('6210fca15799e9affd3cb9dbf29c9e21')
package() {
local a=x86
[ "$pkgarch" == "x86_64" ] && a=x64
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "$srcdir/Etcher-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
+ install -D "$srcdir/Etcher-linux-$a-$realver.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}