summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2016-09-28 12:30:43 -0700
committerMike Swanson2016-09-28 12:30:43 -0700
commiteefa1bf8492461a9838a0c81113f89f034c21d1b (patch)
treeb59a34e7508a652eae3a56ee85ca866863cf1a19 /PKGBUILD
parent9695ac8ab302ec354f23198f29c014d79ccb9967 (diff)
downloadaur-eefa1bf8492461a9838a0c81113f89f034c21d1b.tar.gz
Backport the patch to load Freedoom in Eternity correctly
Also, switching to use GitHub for the source download. Lines in the Zip are in DOS format and I don't know if there are other differences.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 566697153a33..2614d382b473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,35 @@
pkgname=eternity-engine
pkgver=3.40.46
-pkgrel=4
+pkgrel=5
pkgdesc="An advanced Doom port with vanilla compatibility"
url="http://eternity.youfailit.net/"
arch=('i686' 'x86_64')
license=('GPL3')
depends=('sdl' 'sdl_mixer' 'sdl_net' 'zlib')
makedepends=('cmake')
-source=(http://eternity.mancubus.net/ee-$pkgver-src.zip)
-sha256sums=('27c49450fb814c4d9c81e5f2895cbd825f9c7a9f3d024e824ed6feb70ef6965c')
+source=(https://github.com/team-eternity/eternity/archive/$pkgver.tar.gz
+ 0001-Fix-wrong-Freedoom-IWAD-detection-fixes-7.patch)
+sha256sums=('6479c127bdc1986421d0daa821131d21bd3d95621c4181d3528f1efe14c0084b'
+ 'f708c5838e7415e21e0ba4e7c1c01305dca5854f65159989e1fdb06c6f5d9658')
+
+prepare() {
+ cd "eternity-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
build() {
# Cannot do in-tree build.
mkdir "ee-build"
cd "ee-build"
- cmake ../ee-$pkgver-src -DCMAKE_INSTALL_PREFIX=/usr
+ cmake ../eternity-$pkgver -DCMAKE_INSTALL_PREFIX=/usr
make
}