summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Hacohen2018-03-16 14:45:06 +0000
committerTom Hacohen2018-03-16 14:45:06 +0000
commit33bd15e385eaeeb19e72427b5150f5a6271e638a (patch)
tree57b2759185de3e959d042afaf28a6f0c8cdbab9e /PKGBUILD
downloadaur-33bd15e385eaeeb19e72427b5150f5a6271e638a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74d042b3301e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tom Hacohen <tom@stosb.com>
+# Contributor: David Runge <dave@sleepmap.de>
+
+pkgname=etesync-dav
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="A CalDAV and CardDAV front-end/proxy for EteSync "
+arch=('any')
+url="https://pypi.python.org/pypi/${pkgname}/"
+license=('LGPL')
+depends=('python-appdirs'
+ 'python-radicale-storage-etesync'
+)
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/e/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('e5ffeb4c77d1e2ff4a1576619d2931686234ebe519559c4f841b5daf769839ab72decea303fd55b48ac47c80d01022c15cce432ba11962e7116b4da155255554')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}"
+ install -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ -vDm644 {DESCRIPTION.rst,README.md}
+}
+