summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2017-07-09 08:21:16 -0400
committerAdam Goldsmith2017-07-09 08:21:16 -0400
commit4bb10330dad46cd7e9f228173c48dd1b911aadc0 (patch)
treed58c5f0399fecd83ed656b0a8b958c767814ed5a /PKGBUILD
downloadaur-4bb10330dad46cd7e9f228173c48dd1b911aadc0.tar.gz
Initial Commit, v0.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0576789caa9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+pkgname=ethminer-bin
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support (precompiled binary)"
+arch=('x86_64')
+url="https://github.com/ethereum-mining/ethminer"
+license=('MIT')
+provides=('ethminer')
+conflicts=('ethminer')
+source=("https://github.com/ethereum-mining/ethminer/releases/download/v${pkgver}/ethminer-${pkgver}-Linux.tar.gz")
+md5sums=('4bc7be44a622a0372ba45f84027ccae2')
+
+package() {
+ install -Dm755 "$srcdir/bin/ethminer" "$pkgdir/usr/bin/ethminer"
+}
+
+# vim:set ts=2 sw=2 et: