summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2021-05-16 19:29:41 +0200
committermrxx2021-05-16 19:29:41 +0200
commit28e800ec5754249bde6e42996d7936ff459bc44a (patch)
tree266786f3e602a96e413ff3130d463094449e1c9f /PKGBUILD
parentd9ffc48706d0751204081cb5bb583471b1b5cc49 (diff)
downloadaur-28e800ec5754249bde6e42996d7936ff459bc44a.tar.gz
Fix build issues 2290,2262
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a420d75c9da9..3a793bc167cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ethminer-cuda
_pkgname=ethminer
pkgver=0.19.0
-pkgrel=3
+pkgrel=4
pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
arch=('x86_64')
url="https://github.com/ethereum-mining/ethminer"
@@ -24,6 +24,13 @@ build () {
# fix https://github.com/ethereum-mining/ethminer/issues/2027
sed -i '/arch=compute_30/d' libethash-cuda/CMakeLists.txt
+ # fix https://github.com/ethereum-mining/ethminer/issues/2290
+ git cherry-pick 9ceee532cded1983fe0cf6a5cc3be9b39b409705
+ git cherry-pick 671949a73c942593a3cf8318bf67fdb76ac91530
+
+ # fix https://github.com/ethereum-mining/ethminer/pull/2262
+ git cherry-pick 6f85e225748029ab8888fec090305f2a7405f046
+
mkdir -p build && cd build
export CC=gcc