summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-02-27 11:39:27 +0100
committerEmiel Wiedijk2018-02-27 11:41:20 +0100
commit3992523c1109afeb306b60d40def8591f3f58e57 (patch)
tree8f886f6e14194d4741283377bda2948fbc37bdc2 /PKGBUILD
downloadaur-3992523c1109afeb306b60d40def8591f3f58e57.tar.gz
ethminer-cuda - initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdab71b80da9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aimileus <me at aimileus dot nl>
+# Contributor: Afri 5chdn <aur@5chdn.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=ethminer-cuda
+_pkgname=ethminer
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
+arch=('x86_64')
+url="https://github.com/ethereum-mining/ethminer"
+license=('MIT')
+depends=(
+ 'mesa'
+ 'cuda'
+)
+makedepends=(
+ 'cmake'
+ 'python'
+)
+optdepends=('cuda: NVIDIA cuda mining support')
+conflicts=('ethereum')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ethereum-mining/ethminer/archive/v$pkgver.tar.gz")
+sha256sums=('72bf827a922b797d556f8f03980185c4857bb82074b4c8b5f63b5d5e140893b8')
+
+build () {
+ cd "$_pkgname-$pkgver"
+ mkdir -p build && cd build
+
+ export CC=gcc-6
+ export CCX=g++-6
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DETHASHCUDA=ON
+
+ make
+}
+
+
+package() {
+ cd "$_pkgname-$pkgver/build"
+ make DESTDIR=$pkgdir install
+}