summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2020-09-05 23:12:27 +0200
committermrxx2020-09-05 23:12:27 +0200
commit74d2b2bbe181a1be7de61af803e070c0e05c7d39 (patch)
treedfd03c38e76c158827458fde0563d42f73034209 /PKGBUILD
parent66c3192a7eb553c423acb1576d310d53491ab86f (diff)
downloadaur-74d2b2bbe181a1be7de61af803e070c0e05c7d39.tar.gz
Use gcc-9; Fix build issue 2027
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f393e3605399..013f8d7a303c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ethminer-cuda
_pkgname=ethminer
pkgver=0.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
arch=('x86_64')
url="https://github.com/ethereum-mining/ethminer"
@@ -21,13 +21,13 @@ build () {
cd "$_pkgname"
git submodule update --init --recursive
- # add missing library for linking
- sed -i 's/CLI11 Boost::system)/CLI11 Boost::system Boost::filesystem)/' ethminer/CMakeLists.txt
+ # fix https://github.com/ethereum-mining/ethminer/issues/2027
+ sed -i '/arch=compute_30/d' libethash-cuda/CMakeLists.txt
mkdir -p build && cd build
- export CC=gcc-8
- export CXX=g++-8
+ export CC=gcc-9
+ export CXX=g++-9
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DETHASHCUDA=ON
cmake --build .
}