summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSmasher8162017-07-16 21:31:55 -0700
committerSmasher8162017-07-16 21:31:55 -0700
commita1af8c9fbcadc85bfcbb1b9a340d8ce85d8b70f5 (patch)
treef1151b4f3450467dd5ddc947bd3c9008e33d2883 /PKGBUILD
parentf0f8047e006f3f47710f7badae08deb52fa00c38 (diff)
downloadaur-a1af8c9fbcadc85bfcbb1b9a340d8ce85d8b70f5.tar.gz
Switch to cmake for install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd870d55baf2..7d44aaedafec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ethminer-git
-pkgver=0.11.0.0.20170630.7b678d8a4
+pkgver=0.12.0.0.20170716.f99ca9822
pkgrel=1
pkgdesc="Ethereum miner with CUDA and stratum support. chfast's version."
arch=('i686' 'x86_64')
@@ -70,12 +70,8 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "${pkgname}/build"
msg 'Installing...'
- make DESTDIR="$pkgdir" install -C build
-
- msg 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ DESTDIR="${pkgdir}" cmake -P cmake_install.cmake
}