summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-07-27 14:26:46 -0500
committerLuis Martinez2021-07-27 14:26:46 -0500
commit70fd94ed54991997eb7a738a4e89de775f17c7cf (patch)
tree2961f163fe64ee76b043d5b2404e08b7794663c7 /PKGBUILD
downloadaur-70fd94ed54991997eb7a738a4e89de775f17c7cf.tar.gz
initial commit based on evans-bin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47a8e4e0fce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Tiago Cardoso <tbcardoso at outlook dot com>
+
+pkgname=evans
+pkgver=0.10.0
+pkgrel=1
+pkgdesc='More expressive universal gRPC client'
+arch=('x86_64' 'i686' 'arm')
+url='https://github.com/ktr0731/evans'
+license=('MIT')
+depends=('glibc')
+makedepends=('go>=1.13')
+# checkdepends=('git' 'vim')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('1abdd11de767853519d29f0d93ea40a2c9962bc5db6d2a7836e79b29abc8a7c9')
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname-$pkgver"
+ go build
+}
+
+# check() {
+# cd "$pkgname-$pkgver"
+# go test ./...
+# }
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "$pkgname" -t "$pkgdir/usr/bin/"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}