summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Wawrzyniak2018-12-26 14:16:57 -0500
committerMichael Wawrzyniak2018-12-26 14:16:57 -0500
commit432d29bbfafebcf62be0d5930c6f87c16ac6fa12 (patch)
tree89b8a8a4870ce27059a0e4d558341535c295d60a /PKGBUILD
parente22a9c09f952490f3ecb4810cc121df507475472 (diff)
downloadaur-432d29bbfafebcf62be0d5930c6f87c16ac6fa12.tar.gz
Fixed FBINFO_CAN_FORCE_OUTPUT compile error for 4.20
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b357307b65b..a13b19a09765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=evdi
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Linux® kernel module that enables management of multiple screens."
arch=('i686' 'x86_64')
url="https://github.com/DisplayLink/evdi"
@@ -19,12 +19,26 @@ backup=()
options=()
install=$pkgname.install
changelog=$pkgname.Changelog
-source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/v$pkgver.tar.gz)
+source=($pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/DisplayLink/evdi/archive/v$pkgver.tar.gz
+ force_output.patch
+ relro.patch)
noextract=()
-md5sums=('20a69bf61aef388019afb283bb03ea29')
+md5sums=('20a69bf61aef388019afb283bb03ea29'
+ '8ebc776d731166661106b1fb3eeb306c'
+ '05e64dd295a66c030139d0c8f6f7013b')
+prepare() {
+ cd "$pkgname-$pkgver"
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ patch -Np1 < "../$src"
+ done
+}
build() {
-# We only need to build the library in this step, dmks will build the module
+# We only need to build the library in this step, dkms will build the module
cd "$pkgname-$pkgver/library"
make