summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuentin Glidic2017-04-23 14:10:38 +0200
committerQuentin Glidic2017-04-23 14:54:10 +0200
commit2fd3db882f2ba33e42532e3252162c0916acb0f0 (patch)
treed6f1d6288ccb05f6ed997800fe1d7d48ae74d5b3 /PKGBUILD
parent5fde4fa98b9216fa11d27bc755e9fe890599313a (diff)
downloadaur-2fd3db882f2ba33e42532e3252162c0916acb0f0.tar.gz
eventd: Bump to 0.22.0
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8f926ea9a2a..5731a608e072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Quentin Glidic <sardemff7@eventd.org>
pkgname=eventd
-pkgver=0.21.0
+pkgver=0.22.0
_pkgdir=${pkgname}-${pkgver}
pkgrel=1
pkgdesc="A small daemon to act on remote or local events"
@@ -28,6 +28,8 @@ depends=(
xcb-util-wm
)
makedepends=(
+ 'meson>=0.39.1'
+ ninja
libxslt
docbook-xsl
)
@@ -44,31 +46,29 @@ source=(
https://www.eventd.org/download/${pkgname}/${pkgname}-${pkgver}.tar.xz
)
sha256sums=(
- f4e1bf014e3e17bf79d3b2a61d947cf4d34000d35fab0b90b869f33f002d2349
+ c643dde927f1e938898a0196021f3e0f3c6cc369bd133c8ab9d70b333ecc2fa4
)
build() {
local params=(
--prefix=/usr
- --enable-systemd
- --disable-introspection
- --disable-nd-wayland
- --disable-im
- --disable-sound
+ -Denable-systemd=true
+ -Denable-introspection=false
+ -Denable-nd-wayland=false
+ -Denable-im=false
+ -Denable-sound=false
)
cd "${srcdir}"/${_pkgdir}
- ./configure "${params[@]}"
-
- make
+ meson "${srcdir}"/build "${params[@]}"
+ ninja -C "${srcdir}"/build
}
check() {
- cd "${srcdir}"/${_pkgdir}
- make check
+ ninja -C "${srcdir}"/build test
}
package() {
- cd "${srcdir}"/${_pkgdir}
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" \
+ ninja -C "${srcdir}"/build
}