summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuentin Glidic2018-03-07 17:37:44 +0100
committerQuentin Glidic2018-03-07 18:05:37 +0100
commit92ec8f138cb8a2f095fc283ae918df847fc9d68b (patch)
tree5b3306a3008b101732b7c57a64be09a992204ba3 /PKGBUILD
parent982dd2892d1278d88c8b53af1e9ec2c18a1a56e8 (diff)
downloadaur-92ec8f138cb8a2f095fc283ae918df847fc9d68b.tar.gz
eventd: Bump to 0.24.0
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0aae230b8f24..6f9f2c043304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Quentin Glidic <sardemff7@eventd.org>
pkgname=eventd
-pkgver=0.23.0
+pkgver=0.24.0
_pkgdir=${pkgname}-${pkgver}
-pkgrel=4
+pkgrel=1
pkgdesc="A small daemon to act on remote or local events"
arch=(
i686
@@ -23,11 +23,14 @@ depends=(
pango
libsystemd
libxcb
+ 'libxkbcommon>=0.4.1'
+ libxkbcommon-x11
util-linux
xcb-util
xcb-util-wm
)
makedepends=(
+ git
meson
pkg-config
ninja
@@ -47,17 +50,17 @@ source=(
https://www.eventd.org/download/${pkgname}/${pkgname}-${pkgver}.tar.xz
)
sha256sums=(
- fe4905d79c8312686c11db28783364b84216289fd1a7fa58db3137135047dc9e
+ 668f5a56eb156712181176fc4b4f87cd52de919af6e661504ae9e543b4b226a3
)
build() {
local params=(
--prefix=/usr
- -Denable-systemd=true
- -Denable-introspection=false
- -Denable-nd-wayland=false
- -Denable-im=false
- -Denable-sound=false
+ -Dsystemd=true
+ -Dintrospection=false
+ -Dnd-wayland=false
+ -Dim=false
+ -Dsound=false
)
cd "${srcdir}"/${_pkgdir}