summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 20:13:56 -0400
committerXiao-Long Chen2015-06-08 20:14:28 -0400
commit899faec6cee8231103bdea48fdae8c94276b0d3d (patch)
treecfec1a689758c10b1b4dcabfe387d926345fab05 /PKGBUILD
downloadaur-everpad.tar.gz
Import from old AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2daec6c662bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=everpad
+pkgver=2.15.8
+pkgrel=1
+pkgdesc="Evernote client with Unity integration"
+arch=(i686 x86_64)
+url="https://github.com/nvbn/everpad/"
+license=(GPL)
+depends=(python2-beautifulsoup3 python2-dbus python2-keyring python2-magic
+ python2-oauth2 python2-pyside python2-pysqlite python2-regex
+ shiboken python2-sqlalchemy python2-unity-singlet sni-qt)
+makedepends=(python2-distribute python2-webpy)
+# Also python2-html2text
+source=("https://launchpad.net/~nvbn-rm/+archive/ppa/+files/everpad_${pkgver}.orig.tar.xz")
+sha512sums=('2c356ac0f5741fe762aad71715cb97d7d69e6e1ddacb1333cd69f8b8c2521404c6fa131b2f72f772a1ac26e26fb8bda83c0648221e7018eabf2670087159e145')
+
+package() {
+ cd everpad
+
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}