summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2012-02-12 14:10:25 +0000
committerThomas Weißschuh2012-02-12 14:10:25 +0000
commitbc5407befaf758507b0de0d613f323d60fab80f6 (patch)
tree8b3dd3ae8cb5aadc800ef02e73a864f7c970cef3 /PKGBUILD
downloadaur-bc5407befaf758507b0de0d613f323d60fab80f6.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..288f8f99cea5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Thomas Weißschuh <thomas_weissschuh || lavabit || com>
+# Contributor: Zveroy <zy at aafg dot ws>
+# Contributor: Jonas Haag <jonas at lophus dot org>
+# Contributor: Pardi Tommaso <homer.j.simson.bis at gmail dot com>
+
+pkgname=evilvte
+pkgver=0.5.1~pre2
+pkgrel=1
+pkgdesc='VTE based, highly customizable terminal emulator'
+arch=('i686' 'x86_64')
+provides=('evilvte')
+url='http://www.calno.com/evilvte/'
+license=('GPL2')
+depends=('vte3' 'hicolor-icon-theme')
+makedepends=('pkg-config')
+source=("http://www.calno.com/evilvte/evilvte-${pkgver}.tar.xz")
+install=evilvte.install
+
+build(){
+ cd ${srcdir}/evilvte-${pkgver}
+
+ if [ -e ${startdir}/config.h ]
+ then
+ echo config.h found.
+ else
+ cp ./src/config.h ${startdir}/
+
+ echo Please edit ${startdir}/config.h to customize your options.
+
+ if [ -n "${EDITOR}" ] ; then
+ "${EDITOR}" "${startdir}/config.h"
+ fi
+ fi
+
+ cp -f ${startdir}/config.h ./src/
+ ./configure --prefix=/usr --with-gtk=3.0
+ make
+}
+
+package(){
+ cd ${srcdir}/evilvte-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+sha1sums=('e48eb96d24dd5c5ab315c7b489684a7ec7ef0422')