summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Korpel2015-06-10 00:21:37 +0200
committerMarcel Korpel2015-06-10 00:21:37 +0200
commit1a9194e163c1d3df49f506e74cf13fec2d93bb27 (patch)
tree9e5facb3f10644198eaa246eab67a404475f9142 /PKGBUILD
downloadaur-1a9194e163c1d3df49f506e74cf13fec2d93bb27.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36e60ad787c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+
+pkgname=evince-synctex
+_pkgname=${pkgname/-/_}
+pkgver=1
+pkgrel=1
+pkgdesc="Several scripts to ease the use of Evince with SyncTeX"
+arch=('any')
+url="http://forum.ubuntuusers.de/topic/evince-synctex-vim-emacs-scite-lyx-kile-editor/"
+license=('GPL')
+depends=('dbus-glib' 'python2-dbus' 'python2-gobject2')
+install=$pkgname.install
+source=(http://dud.inf.tu-dresden.de/~ben/${_pkgname}.tar.gz
+ $pkgname.patch)
+sha256sums=('65b43f00e894d116bbccf62cac1d6bdd753c6bcb4d0d7f90efbf10c59dc95052'
+ '2a8a5a55c68051f70a2ec8fe1e48b5c9a27f3def29ee4efb2f8e9773afda43cc')
+
+prepare() {
+ cd "$srcdir/${_pkgname}"
+
+ patch -p1 < ../$pkgname.patch
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ install -D evince "$pkgdir/usr/bin/$pkgname"
+ install evince_backward_search \
+ evince_forward_search \
+ "$pkgdir/usr/bin"
+}