summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Latifi2021-12-07 01:58:23 +0100
committerFlorian Latifi2021-12-07 01:58:23 +0100
commitb6e70fd2368736ad4b8ef0f98a67cf5953332b2b (patch)
treea64a6469c67319f7ffaa2d90c637c716decb6906 /PKGBUILD
parent46c05a2069599365633b9a372fa02bd48056d914 (diff)
downloadaur-b6e70fd2368736ad4b8ef0f98a67cf5953332b2b.tar.gz
Update to 2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41dbf7fa35ea..bd7b5b2c7a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
-# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
-# Contributor: Vasket <vasket at dismail dot de>
+# Contributor: Fabio Loli <fabio.loli@disroot.org>
+# Contributor: Vasket <vasket@dismail.de>
+# Contributor: Florian Latifi <mail@florian-latifi.at>
pkgname=evolution-decsync
-pkgver=1.3.0
-pkgrel=2
-pkgdesc="DecSync Plugin for Evolution. It syncs contact and calendars to a directory, which can be shared with syncthing or rsync"
+pkgver=2.0.0
+_pkgver=2.0.0-evolution-3.40
+pkgrel=1
+pkgdesc="An Evolution plugin which synchronizes contacts and calendars using DecSync."
arch=(x86_64 i686 armv7h aarch64)
license=(LGPL)
url="https://github.com/39aldo39/Evolution-DecSync"
depends=(json-c evolution-data-server evolution libdecsync)
makedepends=(meson ninja)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/39aldo39/Evolution-DecSync/archive/v${pkgver}.tar.gz")
-sha256sums=('98defcfd8af9b7a3248e7f2b674975b83e66abee08e949a598815189ea83a4dc')
+source=("https://github.com/39aldo39/Evolution-DecSync/archive/v${_pkgver}.tar.gz"
+ "use-format-string.patch")
+sha256sums=('8772a8fcaf07cffe15163cf4d0b598d2cb8806bea4ddaa9ddfe150771da1679b'
+ '4c2e04a0e2352f22197db66f416670c0eb3da44f4520195e660e804b820388fc')
+
+prepare() {
+ cd "Evolution-DecSync-${_pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/use-format-string.patch"
+}
build() {
- cd "Evolution-DecSync-${pkgver}"
+ cd "Evolution-DecSync-${_pkgver}"
meson build
ninja -C build
}
package() {
- cd "Evolution-DecSync-${pkgver}"
+ cd "Evolution-DecSync-${_pkgver}"
DESTDIR="${pkgdir}" meson install -C build
}