summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Corbatto2016-02-26 19:30:58 +0100
committerLuca Corbatto2016-02-26 19:30:58 +0100
commit7a6c558eb3f9a2f60c5203737b5c2b63a5c00bfb (patch)
treeb88958edb838ddb7469a3a34c68520c31ad1fad2 /PKGBUILD
downloadaur-7a6c558eb3f9a2f60c5203737b5c2b63a5c00bfb.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..063188824565
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Luca Corbatto <luca-arch@corbatto.de>
+_pkgname=evolution-rss
+pkgname=$_pkgname-git
+pkgver=0.3.95.r26.ga6fe830
+pkgrel=1
+pkgdesc="RSS-Plugin for evolution"
+arch=(i686 x86_64)
+url="http://gnome.eu.org/evo/index.php/Evolution_RSS_Reader_Plugin"
+license=('GPL')
+depends=('evolution' 'webkitgtk' 'gtkhtml4')
+makedepends=('gnome-common' 'automake>=1.8' 'autoconf>=2.53' 'intltool>=0.25' 'gettext' 'pkg-config>=0.14.0')
+install=$_pkgname.install
+source=('git://github.com/GNOME/evolution-rss.git')
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ ./autogen.sh --prefix=/usr \
+ --localstatedir=/var
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ git describe --long | sed 's/^EVOLUTION_RSS_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+}