summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-03-19 10:41:50 -0400
committeréclairevoyant2023-03-19 10:41:50 -0400
commit075dc6b9b18067bdd8ee46715b995ce455542066 (patch)
tree0baf3c0b5f0982b35949df9cea69befb11a40bdd /PKGBUILD
parent4f273b3c6538c97aa51474f099bbc533ef274cd3 (diff)
downloadaur-075dc6b9b18067bdd8ee46715b995ce455542066.tar.gz
eww-wayland-git: backport patch to remove box_syntax
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e76235a46de..5fe64413e180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=eww
pkgname="$_pkgname-wayland-git"
-pkgver=0.4.0.r20.g8ff4142
+pkgver=0.4.0.r21.g45154bb
pkgrel=1
pkgdesc="ElKowar's wacky widgets (Wayland build)"
arch=('x86_64')
@@ -14,13 +14,21 @@ makedepends=(git rustup)
provides=("$_pkgname=${pkgver/.r*/}")
conflicts=("eww")
install=$pkgname.install
-source=("git+$url.git?signed")
-b2sums=('SKIP')
+source=("git+$url.git?signed"
+ 0001-remove-box_syntax.patch)
+b2sums=('SKIP'
+ '2953945ff2286fef89c5a08e834221b15900ef43c5422871e247ff5b6c13983f5c7a3869ae9dcc670809b10f921c6d4b822c77d07033bf36d7bf1d285589de20')
validpgpkeys=(
'B558974128820CB473BD9807E321AD71B1D1F27F' # Leon Kowarschick <5300871+elkowar@users.noreply.github.com>
'5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23' # GitHub (web-flow commit signing) <noreply@github.com>
)
+prepare() {
+ cd $_pkgname
+ # pending merge of #711
+ patch -Np1 -i ../0001-remove-box_syntax.patch
+}
+
pkgver() {
cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'