summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAtifChy2021-08-31 00:42:09 +0600
committerAtifChy2021-08-31 00:42:09 +0600
commitbf9a12129a640b2749685cffe4f47d948a4ff8de (patch)
tree5a19d4496207090ecc4aee26d3316482f9eea4ff /PKGBUILD
parenta827e297a5d79a2e1869686c9b425f806c49b861 (diff)
downloadaur-bf9a12129a640b2749685cffe4f47d948a4ff8de.tar.gz
better pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da0cacd979e4..8b2276122064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Atif Chowdhury <iftakhar.awal@gmail.com>
pkgname=eww-wayland-git
_pkgname=eww
-pkgver=70285e0_2021.08.27
-pkgrel=1
+pkgver=0.1.0.r164.g70285e0
+pkgrel=2
epoch=
pkgdesc="ElKowar's wacky widgets (Wayland Only)"
arch=('any')
@@ -27,9 +27,7 @@ validpgpkeys=()
pkgver() {
cd ${_pkgname}
- _commit=$(git rev-parse HEAD | cut -c1-7)
- _date=$(git log -1 --date=short --pretty=format:%cd)
- printf "%s_%s\n" "${_commit}" "${_date}" | sed 's/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {