summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-03-05 22:06:30 -0500
committerTed Alff2020-03-05 22:06:30 -0500
commitb192180e37fda50281c752cb76e98f4b3c7fe017 (patch)
tree8fd0ff584bc2747a5567096f51aa48114ae4340b /PKGBUILD
parent01adb3fd0a87734d86e7d97e3c86ebe0ff22c932 (diff)
downloadaur-b192180e37fda50281c752cb76e98f4b3c7fe017.tar.gz
Update for python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ed8fc98ff63..9d1ad9e4af0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,35 @@
_pkgname=exaile
pkgname=${_pkgname}-git
epoch=1
-pkgver=4.0.0rc5+0+g449775a8
+pkgver=4.0.2+205+gcf9b3e59
pkgrel=1
pkgdesc="music player for gnome, similar to KDEs amarok"
arch=('any')
-url="http://www.exaile.org"
+url="https://www.exaile.org"
license=('GPL')
-depends=('gtk3' 'python2-mutagen' 'python2-dbus' 'python2-gobject'
- 'python2-cairo' 'udisks2' 'librsvg' 'gst-plugins-good')
-makedepends=('git')
-optdepends=('python2-feedparser: podcasts plugin'
+depends=('gtk3' 'python-bsddb' 'python-mutagen' 'python-dbus' 'python-gobject'
+ 'python-cairo' 'udisks2' 'librsvg' 'gst-plugins-good')
+makedepends=('git' 'help2man')
+optdepends=('python-feedparser: podcasts plugin'
'webkit2gtk: wikipedia plugin'
- 'python2-lxml: LyricsMania plugin'
- 'cddb-py: look up CD tags'
+ 'python-lxml: LyricsMania plugin'
+# 'cddb-py: look up CD tags' #from DEPS: (TODO: This is currently broken on python3, see #608 and #652)
'libkeybinder3: Multimedia keys plugin'
- 'python2-beautifulsoup4: Lyrics Wiki plugin'
+ 'python-beautifulsoup4: Lyrics Wiki plugin'
'libnotify: Notify plugin'
'streamripper: Streamripper plugin'
'gnome-screensaver: Pause on screensaver plugin'
'mate-screensaver: Pause on screensaver plugin'
'cinnamon-screensaver: Pause on screensaver plugin'
- 'python2-musicbrainzngs: Musicbrainz cover search plugin'
- 'ipython2: Ipython console plugin'
- 'python2-pylast: Last.fm loved tracks plugin'
+ 'moodbar: Moodbar plugin'
+ 'python-musicbrainzngs: Musicbrainz cover search plugin'
+ 'ipython: Ipython console plugin'
+ 'python-pylast: Last.fm loved tracks plugin'
'gst-plugins-bad: Additional audio codecs'
'gst-plugins-ugly: Additional audio codecs'
'spydaap-git: DAAP server/client')
-
+checkdepends=('python-mox3'
+ 'python-pytest')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
source=("${_pkgname}"::git+https://github.com/exaile/exaile.git)
@@ -43,11 +45,16 @@ pkgver() {
build() {
cd "${_pkgname}"
- make
+ make PREFIX="/usr"
+
+}
+
+check() {
+ cd "${_pkgname}"
+ make PYTEST="py.test" test
}
package() {
cd "${_pkgname}"
make DESTDIR="$pkgdir/" PREFIX="/usr" install
- make clean
}